New York Firearms Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
353 Posts
Discussion Starter · #1 ·
Need some help...I have an 11-87 sportsman. If I load four shells in to the magazine tube, manually operate the action the first shell moves in to battery and can be fired but the bolt locks to the rear and the next shell won't release from the magazine tube. This happens 80% of the time, occasionally I get to fire 4 shots in a row.

I took the gun apart and aggressively cleaned everything. Replaced the o-ring and gas piston assembly....didn't help. I don't think it's an issue of not enough gas because the bolt locks to rear every time.....with light 2 3/4 loads. Cleaned the gas ports...all that stuff.

I'm down to trouble shooting the two latches on either side of the receiver or the magazine tube spring. Does anyone know the correct length of the magazine tube spring????..mine measures 17 1/2 inches. Brownells sells a new one that measures 19 3/4 inches which makes me think the spring is compressed and doesn't have enough force to push the shells from the tube on to the carrier. Any suggestions are appreciated!!
 

·
Registered
Joined
·
9,682 Posts
It sounds like the mag spring to me. I would stretch out the one you have and see if that fixes the issue. If it does order a new one from Wilson Combat and upgrade the follower while your at it.
 

·
Registered
Joined
·
9,682 Posts
I was thinking about doing that I just wanted to verify the correct length...thanks
Length dosn't really matter if the tension is shot. Different types of springs, material, gauge etc can be different lengths with the same amount of tension.
 
1 - 5 of 5 Posts
Top